Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Controller / enclosures not shown/recognized

Hi!

I'm configuring (testing) a new QS setup using HBA (instead of SmartArray controller) and JBOD enclosures.
The server is an older HP DL380G7 machine with a integrated P410i RAID controller and additional HP H221 HBA (LSI2308 chipset).
I have two HP D2700 (25x 2.5") JBOD enclosures attached to the H221 HBA and something like 30 drives/slots filled at the moment.

From the OS standpoint it seems all ok, the controller(s) are there, the enclosures also as are all the drives.

The problem is QS is not showing only the P410i controller in the web-gui. Also there are no enclosures detected/visible (other than the 8-bay internal box attached to the P410i).
This does not seem "right" to me. Am I wrong? Is this a "normal situation"?

lspci shows all the right hardware.

...
04:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet (rev 20)
04:00.1 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet (rev 20)
05:00.0 RAID bus controller: Hewlett-Packard Company Smart Array G6 controllers (rev 01)
08:00.0 Serial Attached SCSI controller: LSI Logic / Symbios Logic SAS2308 PCI-Express Fusion-MPT SAS-2 (rev 01)
0b:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
0b:00.1 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
...

lsscsi show all the right devices

...
[1:0:19:0] disk HP EG0300FAWHV HPDF /dev/sdv
[1:0:20:0] disk HP EG0300FDBAV HPDF /dev/sdw
[1:0:21:0] disk HP EG0300FAWHV HPDF /dev/sdx
[1:0:22:0] enclosu HP D2700 SAS AJ941A 0150 -
[1:0:23:0] disk HP DG0300FARVV HPDG /dev/sdy
[1:0:24:0] disk HP EG0300FBDBR HPDA /dev/sdz
[1:0:25:0] disk HP EG0300FBDBR HPDA /dev/sdaa
[1:0:26:0] disk HP EG0300FBDSP HPD6 /dev/sdab
[1:0:27:0] disk HP EG0300FBDSP HPD6 /dev/sdac
[1:0:28:0] disk HP EG0300FBDBR HPDA /dev/sdad
[1:0:29:0] disk HP EG0300FBDSP HPD6 /dev/sdae
[1:0:30:0] disk HP EG0300FBVFL HPDE /dev/sdaf
[1:0:31:0] disk HP EG0300FBDSP HPD6 /dev/sdag
[1:0:32:0] disk HP EG0300FAWHV HPDE /dev/sdah
[1:0:33:0] enclosu HP D2700 SAS AJ941A 0150 -
[2:0:0:0] storage HP P410i 6.64 -
[2:1:0:0] disk HP LOGICAL VOLUME 6.64 /dev/sda
[2:1:0:1] disk HP LOGICAL VOLUME 6.64 /dev/sdb

??
What am I doing wrong?

To "see" the enclosures is important because of drive placement etc.

Regards,
M.Culibrk

April 25, 2019 | Registered CommenterM.Culibrk

Hello,
Reviewing this with OSNEXUS engineering, I found support the H241 and newer HBA's. We will be happy to work with you to add support for the older card. Unfortunately we do not have a H221 card in our lab but are willing to investigate adding this. To support this card, we will need to collect logs from your system and our hardware developer may need additional information.

To gather logs:
If you have version 4.3.0 or above, simply click the "Send Support Logs" button on the Storage
Management tab in the QuantaStor web ui.

Thanks,
Bill Saunders
OSNEXUS Customer Support
email: support@osnexus.com
t: 1.866.219.1757 | 425-279-0172
Contact us | http://www.osnexus.com

April 25, 2019 | Registered CommenterBill Saunders

Fantastic!

I just sent the "support logs" as you requested. I do not know how you "identify" the system but here are some info to let you easier find my logs:

version 5.2.0.088
UUID 7d96dc83-3940-183f-f1ce-f42a84e8c0aa
Activation Key 2E6F-727B-9A7F-91F1
Company Infohit Computers d.o.o.
Full Name Mauricio Culibrk
Internal ID 661a3ce3-a401-88fb-93d1-c4f2d8914bff
Name E60F-9683-DEB749-03D1
Storage System data-lj-00

If you need anything else (remote access, files, screenshots etc) just let me know.

The mentioned card H221 is basically a LSI 2308 branded by HP... I think it's not actually "that old" as a HBA... ok, it's (only) 6G but those are still widely used, aren't they?

Also... where could I get some more info on "defining/creating" some "custom" enclosure definitions?
As the enclosure in the DL380 G7 is not recognized correctly nor is there a "option" to select something more appropriate from the list of supported enclosures.

I'll try to put the boot disk and H221 HBA in a newer DL380 G8 server to check if there are any differences in detecting/showing the "correct" layout/components.

Best regards,
M.Culibrk

April 25, 2019 | Registered CommenterM.Culibrk