Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > iscsi paths issues simulation

Hi

considering my quantastor has 2 ip configured (ip1 and ip2), with iscsi enabled : when I present a lun to my iscsi initiator, the host see 2 paths

[root@node-1-2 /]# multipath -l
26631653662363336 dm-2 OSNEXUS ,QUANTASTOR
size=1.0G features='0' hwhandler='0' wp=rw
|-+- policy='service-time 0' prio=0 status=active
| `- 5:0:0:0 sdb 8:16 active undef unknown
`-+- policy='service-time 0' prio=0 status=enabled
`- 7:0:0:0 sdd 8:48 active undef unknown

How can I simulate the loss of 1 path on the quantastor side ?
I searched in the interface, and I did not find any menu to (temporary) disable the lun presentation through only 1 IP.

Any suggestion ?
Thanks
DD

August 7, 2018 | Registered CommenterDisk Dur

Hello,

I would suggest a good way to test a failure would be to disable one of the IPs by changing the port to 'Disabled'.

Kind Regards,
Josnua Blake

August 9, 2018 | Registered CommenterJoshua Blake

Greetings,

You could also use the alternate method of disabling one path at the multipath layer:

** Take the path offline
# echo "offline" > /sys/block/device_name/device/state

** Rescan the disk devices
# qs disk-scan

** Re-enable the path
# echo "1" > /sys/block/device_name/device/delete

** Rescan the disk devices
# qs disk-scan

August 9, 2018 | Registered CommenterRobert Staffeld

Dur,
Another option would be to just disable ISCSI access on one of the ports. In the web interface, choose 'Modify Network Port' on one of the two ports then uncheck the 'iSCSI Enabled' box to disable iSCSI access on that port. This will update the allowed portals setting on the volume so that only that one remaining port will allow access.
Best,
Steve

September 1, 2018 | Registered CommenterSteve