Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Not detecting Checksum Errors on ZFS zpool drive.

I am running Quantastor 4.x

Distributor ID: Ubuntu
Description: OSNEXUS QuantaStor / Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

When I do a scrub I get

status: One or more devices has experienced an unrecoverable error. An
attempt was made to correct the error. Applications are unaffected.
action: Determine if the device needs to be replaced, and clear the errors
using 'zpool clear' or replace the device with 'zpool replace'.
see: http://zfsonlinux.org/msg/ZFS-8000-9P
scan: scrub repaired 7.57M in 4h4m with 0 errors on Fri Oct 13 18:43:46 2017

But the Quantastor admin does not show anything wrong with the disk and never shows a problem, but this disk always reports CHKSUM errors.

It's software raid on JBOD with no raid controller, but I see no way to replace this disk from the admin.

My questions are A) why doesn't quantastor pickup the bad checksums and warn the admin of pending failure , 2) How do you do replace a disk from the ADMIN ?

THanks

November 7, 2017 | Registered CommenterSyn Dragon

Hi Syn,
To replace a bad drive you would add a Hot-Spare to the pool then remove the bad drive. QuantaStor will see the disk as then failed and will engage the hot-spare in to repair the pool. You should be getting an alert when there are checksum errors detected like that. Could you contact us at support@osnexus.com and send us some logs, we'd like to get a closer look. Were you running the scrub from the QuantaStor web UI as a task or running it manually at the console/ssh?
Best,
-Steve

November 17, 2017 | Registered CommenterSteve