Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Storage volume - snapshot schedule - access snapshot??

Hi there!
I'm experimenting and evaluating QS and so far it seems really great... but I encountered a strange problem.
I have a snapshot schedule for storage volumes (exported via iscsi to some esx hosts) which daily makes the snapshot of all the selected volumes - that seems to work great.
The problem is I needed to actually access the date on one of this snapshots.... and here the problems started.

The volume snapshots have a little gray "down arrow" on them so they are "inactive", right?
There are no zvol devices for those snapshots visible on the system.
The property snapvols is set to hidden (default) on all storage volumes. ZFS list -t snap shows the snapshot nicely.
Any action I try through the QS web gui results id errors like: "Failed to rename storage volume with ID '9a935afc-660f-7b09-bb04-95f9886fb490', unable to locate specified zvol device. [err=1]"
If I create a snapshot of the volume manually it's working as expected - snapshot is created, zvol is there, the snapshot can be exported an accessed via iscsi normally.

I also tried to clone one of the auto-generated snapshots and also tried to make a clone of the snapshot but all failed with similar errors - "unable to located zvol or device"

How can I access the snapshot created by the snapshot-schedule?
I really need the older version of the data there...


January 28, 2017 | Registered CommenterM.Culibrk

Hi M,
Thanks for the feedback. QuantaStor does was we refer to as "lazy cloning" so that the extra resources a clone takes up isn't taken until it is needed. If you assign the snapshot to a host or modify the volumes settings in any way it will automatically manifest into a full storage volume by cloning it behind the scenes. At that point the offline status (shown with the grey down arrow) will go away.

>I also tried to clone one of the auto-generated snapshots and also tried to make a clone of the snapshot but all failed with similar errors - "unable to located zvol or device"

Hmm, interesting, that doesn't sound right. Please contact us at on Monday and we'll assist. If you have a Gold or Platinum license key feel free to write support here on the weekend for immediate assistance.


January 28, 2017 | Registered CommenterSteve

M, I just got some feedback from the support team. Could you try upgrading to the latest version (v4.1.5) there was a minor regression in one of the v4.1.x releases where it wasn't properly etherealizing the snapshot into a clone and that was fixed in QS v4.1.4.

January 28, 2017 | Registered CommenterSteve

First of all... THANKS for a really quick response! :)

Currenty the systems runs QS v I'll try to upgrade and report back if that helped...

I did assign the snapshot to some hosts, that went OK in the meaning that the task reported "Success"... but SCST on the other hand complained about "missing device xxxxxxx" (a longer hex string) and no new lun was exported...

Also any other action on those snapshots resulted in failures (unable to change/set compression/sync/rename... or missing dataset xxxxx etc)

I'm going to upgrade and retest and let you know it that solved the problem.

Again, thanks!


January 29, 2017 | Registered CommenterM.Culibrk

Success! :)

With the new QS version the before mentioned problem is solved! Great!
I had to create a new snapshot schedule because with the original it would not work (the snapshot is now shown as "Normal" status but no zvol is created when assigning the snapshot to a host)

So... thanks again for your help & support!


January 30, 2017 | Registered CommenterM.Culibrk

You're welcome, thanks M!

March 3, 2017 | Registered CommenterSteve