Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Error creating pool [SOLVED v4.1.6]

i tried to create a pool, using ZFS default parameters, which included compression.
This failed with : Storage compression is not licensed for this storage system. [err=51]
although according to the licencing matrix it should be included in Community edition.
The Compression part is not that important to me, but now i am unable to create any pools, it all fails with this:
License space limit exceed by 1.99TB, cannot create/grow storage pool due to insufficent licenses (20.0TB limit). Please contact your OSNEXUS representative regarding an add-on license. [err=175]
It looks like the first attempt has used the license without creating the pool.
is there any way to reset this without resetting the entire installation, and reactivating?

December 24, 2016 | Registered CommenterChristian Eger

Hi Christian,
Just wanted to followup and make sure everything is working fine with the new license key that we sent you. The next update, v4.1.6 will have a change to it so that we no longer limit compression on the Community Edition or any Edition of QuantaStor.
Happy New Year,

January 3, 2017 | Registered CommenterSteve

Hi Steve,
The new license solved the problem, everything works great now.
Thanks :)

Happy New Year,


January 3, 2017 | Registered CommenterChristian Eger

Hello Steve,

Since I am experiencing the same issue, can you please make available the updated license that is addressing it?

Thank you,

January 10, 2017 | Registered CommenterLaurentiu Simion

Hello Lou,

QuantaStor 4.1.5 includes a fix that addressed this limitation in the Community Edition.

Please update to the latest release.

Change Log:

Thank You,
Chris Golden

January 20, 2017 | Registered CommenterChris Golden