Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Quantastor performance

I made two tests and there is big difference in results, maybe somebody will help me how to resolve the problem,
OS in both tests is Windows 2012, Oracle is 11gR2;
test 1: PC with 16 GB RAM, 1xHDD with OS and Oracle Server, 1xSSD for database,
from other workstation I run an application with complex select to database, it lasts about 2:30 min, time is OK, it is a base for test 2;

test 2: server HP with 20 GB RAM (old machine), 1xHDD with OS and Oracle,
PC with 16 GB RAM, 1xHDD for Quantastor, 1xSSD is a storage for database,
2xiSCSI connection uses MPIO, it gives 2Gbps, all NICs use Jumbo frames.
Storage for database has Enable Compression set on and I/O Profile is Default SSD.
When I run the same application with the same select it lasts about 3x longer and average is 7:30 min.

What and where should I correct that both tests time be almost the same? I use free licence of Quantastor.

September 24, 2015 | Registered CommenterAndrew

Hi Andrew,
If I understand correctly in 'test 1' (T1) you're using local storage correct? In that configuration you have none of the network overhead or limits associated with your dual 1GbE iSCSI configuration of configuration T2. If you run an iozone or other performance test within T2 you'll find that the disk performance is likely the same as the disk performance as your T1 configuration. The bottle neck is likely the network. I recommend trying again with dual 10GbE as the 2GbE connection you have will likely yield no more than 160MB/sec.

October 4, 2015 | Registered CommenterSteve

Hi Steve,
yes, T1 was made locally and everything was perfect. I did some performance tests in T2, I used 'HD Speed' and 'ATTO bench', disk performance was OK.
But when I run an application that connect to database and execute select the disk performance (Quantastor storage) is weak.
I don't think so that the network is bottleneck because all operations are made on the storage, in this case, PC.
I just wonder, when I execute select to the database which is locally (T1) it works very fast, when the select is executed remotely (T2) it works very slow.

October 6, 2015 | Registered CommenterAndrew

Hello Andrew,

What Type of SSD are you using in your testing? Is it an enterprise/DC SSD disk?

We have found that Database workloads offer poor performance on Consumer/workstation style SSD's as Database performs many low queue depth SYNC based writes.

Please let us know if you have any other questions.

Thank You,
Chris Golden

October 7, 2015 | Registered CommenterChris Golden

Hello Chris,
thank you for quick answer and explanation, I use Consumer Solution SSD. So, if I want to use SSD for databases I should by Enterprise class SSD?

best regards,

October 8, 2015 | Registered CommenterAndrew

Hello Chris,
one more thing, maybe you will know the answer, why this SSD works very fast just like in test 1 about which I aformentioned earlier, it is 3x shorter then in test 2.
Maybe you have some hint how to resolve this performance.


October 8, 2015 | Registered CommenterAndrew