Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > Hung transfers using NFS

I'm getting hung transfers on write using ZFS storage pools when accessed via NFS. I see some decent throughput but then the transfer hangs for several minutes before finally completing. This is just on a single write operation.

I've seen some various posts on the Linux ZFS Github with the same errors, but can't find any specific fix for it. My setup is two Quantastor VMs running under ESX 5.5 with two 2TB VMDKs on each appliance combined into a Raid-1 storage pool. I'm then creating an NFS share on the pool. The issue happens on either host.

My network stats are great between the client and server, a standard IPerf tests results in 9.88Gbps throughput.

February 1, 2015 | Registered CommenterPhil B

Hello Phil,

Are you mounting the NFS share on your clients in sync or async mode?

Can you provide detail on the hardware you are using for your ESXi host?

Thank You,
Chris Golden
OSNEXUS support

February 2, 2015 | Registered CommenterChris Golden

Hi Chris.

I shutdown the Quantastor VMs, deleted/re-added the virtual disks, brought the VM back up, and I'm no longer getting the same XFS errors and hanging writes. I tried in both async and sync on the client and saw no errors. Does Quantastor use async or sync on the server end?

One issue is Quantastor still has a storage pool and share that were tied to the previousl disks, and there seems to be no way to delete them with the disks missing. The UI just gives an error when try to delete them.

The ESX host is a dual Xeon box, I'm allocating 64GB of RAM and 2 VCPUs to the Quantastor VMs.

As an aside, I thought when I first loaded the GUI it had some Ceph management options, but since rebooting I no longer see them at all. Was I just imagining things? I see the GlusterFS management tab but no longer see one for Ceph.

February 3, 2015 | Registered CommenterPhil B

Hello Phil,

Thanks for the update.

Regarding you hardware configuration, do you have any details on the disk configuration? For best performance on QuantaStor VM appliances we generally recommend giving direct access to disks via either direct lun mapping or using PCI-passthrough of a PCI HBA or RAID controller.

If you have a Storage pool appearing that has disks that are no longer physically present, you can use the 'Export Storage Pool' option on the right click menu to remove it from the QuantaStor system.

Yes, we have some Ceph support included in the product starting with the 3.14 release. We will be launching a pilot program here soon that will provide details on how to enable the Ceph features for testing. If you are interested in joining the Ceph Pilot Program, please contact our sales team at sales@osnexus.com


Thank You,
Chris Golden
OSNEXUS Support

February 3, 2015 | Registered CommenterChris Golden

I'm going to redo the test using a controller passthrough. I realized when it was working okay, I was using a storage pool formatted as XFS, not ZFS. The emulated disks seem to have an issue with ZFS and consistently hang.

Thanks for the export storage pool option, it did clear out the old defunct storage pools.

February 4, 2015 | Registered CommenterPhil B

So this seems to be an issue with Ubuntu and ZFS while using the VMWare ESX virtual drives. I saw the same issue with another solution using Ubuntu 14.04, so for the heck of it I just tried a base Ubuntu install and saw the same issue. It doesn't seem to occur with Centos 6.5 though. I'm not expecting to see an issue at all when using the passthrough mode which I will try today.

February 5, 2015 | Registered CommenterPhil B