Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.

Community Forum > SOAP authentication problem

I am trying to connect to the service, but i get errors. In the log file there is:

{Mon Nov 24 08:30:05 2014, WARN, afb5700:security_manager:286} No SOAP username or password has been supplied to authenticate.
{Mon Nov 24 08:30:05 2014, *ERROR*, afb5700:cmn_object_util:49} Specified 'name' is empty, you must specify a valid name containing only alpha-numeric characters and these characters contained within single quotes: '-_.:@' [err=19]
{Mon Nov 24 08:30:05 2014, *ERROR*, afb5700:security_manager:596} Authentication failed, please re-verify your username and password. [err=26]

Does anyone have any idea how the user name and password should be sent? I have tried "basic" http authentication, but it didn't work. I have also tried authentication by soap header, but it also gives errors (server does not seem to understand this authentication). Please help.

Kind regards

November 24, 2014 | Registered CommenterEd Moss

Hi Ed, are you using the REST APIs? I the Developer Guide it outlines how to pass user/pass using the curl command line utility to the REST interface on port 8153.
Best,
-Steve

November 24, 2014 | Registered CommenterSteve

Hello Steve,

Thanks for the reply. No, I am trying to use the web services API on port 5151. I tried to authenticate through http (basic authentication). It did not work. I also tried to use SOAP headers with no success. I just get this error in the logs (as seen above): "No SOAP username or password has been supplied to authenticate.

I generated a proxy from osn.wsdl file provided with the system and now I am trying to customize it so it works.

Kind regards
Ed

November 27, 2014 | Registered CommenterEd Moss